Not able to deploy to BizTalk 2010

When opening an existing BizTalk solution from designed and build for BizTalk 2006 in VS 2010 and deploying to BizTalk 2010 I got an odd error.  The solution builds fine but i cannot get it to deploy..
 Error 7 Access to the path 'C:\Users\eriei\AppData\Local\Temp\BT\PID13428\BizTalkAssembly\0b2cb3ce88fbfe1e5d4e7cc6158a6fd1\Statoil.BizTalk.Utility.Archive.ContentManager.ControllerTestApplication.dll' is denied. 0 0


When trying to delete the file from this location the error message chagned to 


Error 64 Failed to add resource(s). Change requests failed for some resources. BizTalkAssemblyResourceManager failed to complete end type change request. Assembly "C:\Users\AppData\Local\Temp\BT\PID3724\BizTalkAssembly\63870f24efcb5f96ec704df4b0b0e533\KHS.834Membership.BizTalk.Orchestrations.dll" does not appear to be a BizTalk assembly, and cannot be deployed to the Configuration database. If this assembly is referenced by other BizTalk assemblies, it needs to be installed into the global assembly cache (GAC) of each BizTalk server. 


It seems that to fix this you need to add som information about the assembly to the AssemblyInfo.cs.


I added this 



[assembly: AssemblyVersion("1.0.0.0")]
[assembly: AssemblyFileVersion("1.0.0.0")]
[assembly: Microsoft.XLANGs.BaseTypes.BizTalkAssembly(typeof(Microsoft.BizTalk.XLANGs.BTXEngine.BTXService))]


And voila the solution will depoloy

Comments

Popular posts from this blog

The Messaging Engine failed to register an adapter "WCF-BasicHttp". Details: "Registering multiple adapter types within the same process is not a supported configuration. For e.g. HTTP and SOAP receive adapters cannot co-exist in the same process

Fully Qualifyed Name

Using the BAM API to write BAM events from orchestrations